
Base Platform Release Notes 5.0 
 

New features and enhancements 

• There is a new Sidebar tab "Favorites" that lets you save a list of commands, queries, 
Query tool reports and placers that you use often and want quick and easy access to. 
[3444], [12959]  

• The dialog that shows the history of an object (Show > Object history) can now also 
show modifications made to relations to/from the object (i.e. object links). [4707]  

• The export dialog for DGN, DXF and other file formats have been re-designed for 
improved work flow. [5887], [17816]  

• The "File" menu has been re-designed so that it groups similar functions better and 
avoids unnecessary text duplication. [6452], [15160]  

• When opening an attribute dialog the focus is now on the first input field instead of on 
the tab. [7504]  

• Posting or undoing an empty change set now displays the same message: "There are 
no unposted objects". [9642]  

• Commands in the pop-up menus, displayed when right-clicking on objects, are now 
grouped with separators. Grouping is done the same way as in the drop-down menus. 
[9929]  

• The login dialog has been re-written so that it will load more quickly and only load 
the parts of the application that is actually used. [10369]  

• The Geometry dialog (Show > Geometry for component) now opens with the 
geometry tree fully expanded and all coordinate vertices selected. This way, all the 
component's vertex indicators are immediately displayed in the graphical view. 
[11736]  

• When the user tries to open a geo-referenced image file of a format that is not 
supported, a dialog is now displayed informing the user of this. [11828]  

• The function Show > Command history now displays a sub-menu with the latest 
commands used (previously a pop-up menu). [12392]  

• It is no longer possible to move vertices (using the Move vertex tool) outside the 
coordinate bounds. [12728]  

• The Show states tool (Show > States) can now be used to display also state values that 
are inactive. [12863]  

• It is now possible to grant users the right to edit specific codelists only. The Codelist 
manager tool checks insert and update permissions before the 'Add' and 'Edit' [codelist 
value] buttons are enabled. [13029]  

• When exporting geometries to DXF, Z values are now included in the export file. 
[13279]  

• When posting a change set the user may append a comment describing its contents. 
Also, post comments are searchable using a new report in the Query tool (in the 
Change set folder in the Reports tab). [13413], [17940]  

• Thematic map legends now uses address sorting instead of alphanumeric sorting, 
meaning mixed strings (such as addresses) are sorted correctly. [13495]  

• When using the Disconnect tool (Edit > Disconnect) connected objects are 
highlighted to make selection of eligible objects easier. [14536]  



• There is a new tool to update attribute fields of multiple objects at one time (Tools > 
Mass attribute update). The object subset may be selected, highlighted, traced or 
change set objects. The tool is initially configured for the power application Facilplus 
Spatial/E. [14708]  

• When a DWG file is loaded as a reference file the map legend now displays layer 
names instead of generic names. [14870]  

• The tool "Highlight in color" is now available in all applications. The tool allows the 
user to highlight one or more objects in any one of fourteen available colors. [15326]  

• It is now possible to place leader lines adjusted to text components. This is in use in 
the power application Facilplus Spatial/E in version 5.0 and will be implemented in 
other applications in coming releases. [15789]  

• It is now possible to run post checks ( File > Run post checks) without actually 
posting. [15964]  

• The user is now notified of any locked objects when trying to change the state of 
several objects, while using a pessimistic change set. The user may then proceed to 
change the state for the objects that are not locked. [16006]  

• When editing coordinate values of placement or break points (Edit > Component > 
Set coordinates) the user can now also edit Z values (height). [16084] 

• A new Java-based DXF writer has been developed and implemented in 5.0. The old 
Kartago-based writer is available in parallel until 5.2. [16515] 

• It is now possible to convert DXF to DPS (in addition to the previously available 
DGN and SHAPE to DPS converters). [16726]  

• The Command tree (under the Command tab in the Sidebar) now shows the menu 
icons found in the menu bar. [16930]  

• Hovering the cursor over a codelisted attribute field now displays a tooltip showing 
the name of the codelist employed. This tool also works with empty codelists and in 
instances where an attribute value has not been selected ("Undefined"). [17038]  

• The user now may edit the position of text frames individually in multi-page printouts 
in the Free plot tool. [17243]  

• When opening a DGN file it is now possible to select color tables from a local disk or 
from the server. [17423]  

• Paths to linked documents in attribute forms are now saved and used as the default 
directory. [17637]  

• When resolving change set conflicts, it is now possible to retry the post operation 
from within the conflicts dialog. [17778]  

• A selection of search queries (e.g. available in the Sidebar) is now displayed with 
icons. [17830]  

• The dialog used when selecting the coordinate system to be used in the active 
graphical view has been redesigned and made clearer and more intuitive (Settings > 
Set coordinate system). [17833]  

• The Free plot tool now appears either in the Sidebar or as a floating window 
depending on whether the Sidebar is shown or hidden. [17890]  

• When exporting the geometries of a component (Show > Geometry for component) to 
the Excel format, column headers now include Northing (N) and Easting (E) 
information. [17906]  

• A new menu command, File > Page setup, allows the user to enter paper size and 
orientation settings that are retained throughout the work session. This way the page 
setup is performed only once prior to using the Free plot tool, not for every 
consecutive use of the tool. [17917]  



• DP/Spatial is now run using the Java Web Start technology. One of its many 
advantages include logging in from a separate java window, which eliminates the risk 
of inadvertently closing the application by exiting exiting the log-in page, as was the 
case in the previous browser-based solution. Another difference is that pressing 
Cancel in the login dialog when running Web start closes the login dialog (when the 
applet technology is used, canceling the login redirects the web page to Digpro's 
homepage). Memory allocation and cashing have also been improved. For details 
about configuration options available in Java Web Start, please refer to the abridged 
Release Notes (available in Swedish). [17920], [18025], [18371]  

• When placing free texts, e.g. a free unpostable text, the last 15 texts entered are now 
stored and can be selected from a drop-down list. [17933]  

• The SVG export (File > Export > SVG) has been updated so that it presents the same 
options, i.e. to define an area to be exported, as the other vector file format exporters. 
[17941]  

• Icon loading on startup has been improved so that logging into DP/Spatial on a slow 
network connection is now much faster. [18002]  

• The associated DBF file for rendering of drawing attributes is now used when 
opening an ESRI Shape file (File > Reference data > Open vector file > Shape). 
[18049]  

• To save space the checkbox option "result as file (all rows)" has been removed, 
instead this option has been added to the "Result as Table/Tree" combo box. [18050]  

• It is now possible to export the data in a change set to the Excel format, from the New, 
changed or deleted objects dialog (File > Show changes). [18058]  

• When using the TAB key to navigate to a data field in e.g. an attribute form, the 
contents of the field is highlighted, making it immediately editable. [18060]  

• Double-clicking in a date field now inserts the current date. [18061]  
• There is a new Search query (in the External services folder) called 'Where am I?', 

which describes the user's geographical location (the location of the center of the 
active graphical view). [18136]  

• The ".txt" file extension is now automatically given when exporting to a text file 
format from the Query tool. [18138]  

• It is now possible to export to the ESRI Shape file format (File > Export > Shape). 
[18142]  

• The ".dxf" file extension is now automatically given when exporting map data to the 
DXF file format. [18204]  

• In the Query tool, the user may now limit the number of rows (hits) shown to the 
additional pre-set values 2 500, 5 000, 10 000. [18250]  

• When importing a DXF file to the application, any error log that may be written is 
now displayed to the user, e.g. mismatching mappings in the adjoining map file. 
[18264]  

• It is now possible to select multiple DXF files when importing DXF data to the 
application (using the Ctrl key). [18349]  

• The login dialog now displays a warning if Caps Lock is active when entering the 
password. [18359]  

• The Buffer zone tool has been moved from the Create menu to the Tools menu. 
[18404]  

• When exporting to Excel in the Query tool, the user now has the option to export the 
entire search result or only a subset of selected hits (rows). [18416]  

• Error messages given at Post checks (File > Run post checks) are now more 
descriptive and easier to interpret. [18449]  



• The sidebar tabs now display icons in order to make identification of wanted tab 
easier. [18752]  

• The Administrate change set dialog (Administration > Administrate change sets) has 
been extended to display information about the type of change set, Optimistic or 
Pessimistic. [18797]  

• When resolving a change set conflict, the user may now select to synchronize to either 
version in the conflicting change sets only. The previous attribute value (original 
database attribute) is visible but no longer selectable. [18832]  

• The warning dialog Please note that the original owner of the change set will be able 
to edit the set until he logs off that was displayed when administrating change sets has 
been removed, because the warning is superfluous in that user scenario. [18902]  

• It is now possible to rename user-defined queries in the Query tool. [18915]  
• The map sheet filter function in the DXF export is no longer case sensitive. [19171]  

Corrections 

• States that the user does not have read or write permissions to are no longer selectable 
in the Change state dialog. [5390]  

• Loading a DGN reference file on login did not use the previously selected color table. 
[9056]  

• Background rasters now handle lat/long coordinate systems better. [10146]  
• When trying to display an object in a new window, using a map product without 

components for the selected object type, you get a chance to choose a new map 
product. The new window is now re-used when the user selects the new map product 
thus avoiding to get two new windows as was previously the case. [10646]  

• The Rotate view tool in the Free plot preview did not work in an understandable way, 
now it is more intuitive. [11480]  

• The DWG reference file loader sometimes put blocks in the wrong place, this has 
been corrected. [11590], [11593], 16321]  

• The client no longer sends geometry load requests for raster components that the 
server does not have, thus avoiding unnecessary warnings in the java console. [12209]  

• Some tables did now allow unmarking of rows, this has been corrected. [16714]  
• In printouts from the Free plot tool, the entered scale is now retained correctly in both 

portrait and landscape page orientations. [17019]  
• The hourglass is now again shown when the application loads after log-in. [17260]  
• The Web start technology implementation solves some interface issues, such as 

missing language entries, that could arise when a user was logged into different 
DP/Spatial applications simultaneously. [17391]  

• WMS layers were not rendered correctly at very small map scales, this has been 
corrected. [17771]  

• All occurrences of the GUI text "Scale" has, where applicable, been replaced with the 
more accurate term "Scale factor". [17785]  

• Snapping to a midpoint on a line segment of a reference file now works as intended. 
[17828]  

• The DGN loader now retains the justification (insertion) point of texts components 
correctly. Previously, texts were always given a bottom left justification point by 
default. [17829]  

• If multiple attribute forms are open at the same time, they are now non-modal, i.e. 
they can all be edited and handled independently. [17888]  

• The language drop-down list in the login dialog is now sorted alphabetically. [18099]  



• Only integer values can now be entered when setting the grid dot size for Bigger 
every in the Grid dialog (Settings > Grid > Dialog..). [18103]  

• A bug causing the DGN importer to crash on some shared cells has been fixed. 
[18190]  

• The order of the OK, Cancel and Apply buttons were wrong in a few dialogs, this has 
been corrected. [18221]  

• Non ASCII characters such as å, ä, ö could sometimes be written incorrectly in 
exports to Excel. [18263]  

• Several issues regarding DXF data handling have been addressed, including incorrect 
parcing of data tables, invalid color and Nan values, and exaggerated text sizes in 
exports. [18268], [18285], [18286], [18333]  

• It is now possible to select a symbol by clicking at its insertion point, e.g. the center 
point of a circle or a square. [18296]  

• Rasters were in some cases displayed in the map outside of their configured scale 
ranges, this has been fixed. [18328]  

• The coordinate selection dialog now correctly displays information and sets the 
coordinate system for the currently active view instead of using the view that was 
active when the dialog was opened. [18350]  

• Restarting "Move Component" and "Move Object" in the middle of a move made it 
impossible to move components. [18391]  

• It is no longer possible to open an application using an optimistic change set if that 
application is configured for the pessimistic change set type only. [18394]  

• The DXF map file generator (File > Import > DXF > Generate DXF Map file) will 
now automatically insert quotes around layer names that contain spaces. Spaces in 
layer names previously caused the import to fail, and required manual editing of the 
map file. [18433]  

• The Command history could sometimes show empty menu items, this has been fixed. 
[18440]  

• Show components for object now displays the fields DP_OTYPE and DP_OID again. 
[18448]  

• An unpredictable behavior of the display warning cursors (Component not visible in 
the current map scale and Invalid map product), which sometimes resulted in warning 
cursors being displayed also when they shouldn't be, has been corrected. [18466]  

• It was previously possible to select more than one item in the Query tool and 
seemingly start queries for all selected items. The queries however did only use the 
last selected item. This has now been corrected so that it in this context only is 
possible to select one item at a time. [18468]  

• There were instances where segments were not rendered continuously when placing 
line graphics in the map, especially while repeatedly zooming in and out in the 
graphical view. This is now corrected. [18469]  

• Missing symbol fonts disabled the use of north arrow in the Free plot Preview. This is 
corrected (and also merged to 4.8 in svn: 78884). [18489]  

• User-defined adjustments of drawing attributes (Scale dependent, Show, Hide) were 
not retained in the Free plot Preview, with the print option View settings selected. This 
has been corrected. [18539]  

• Scaling and transformation for RDW files could give wrong values, this has been 
fixed. [18550]  

• Copy polygon now also copies the holes of the polygon. [18556]  
• Copy polygon now handles circular arcs in the edges correctly. [18566]  



• Raster maps were in some scales not shown even though right-clicking and selecting 
Show from the Legend settings, this has been corrected. [18581]  

• There was a problem with the right-click functionality in the Conflict dialog, this has 
been corrected (and also merged to 4.8 in svn: 79776). [18583]  

• Loading of the configuration file for raster now handles raster split into several 
directories. [18818]  

• In the result of the Query tool report Number of changed objects in change sets the 
change set type (optimistic/pessimistic) was switched. This has been corrected. 
[18869]  

• Some attribute dialogs did not close when the user logged out, this has been fixed. 
[18884]  

• Reading of DGN files with very large cells now works correctly. [18989]  
• When loading several Shape files, each file is now given a unique name in the Legend 

tree view. Previously, consecutive files inherited the name of the file that was loaded 
first. [19068]  

• The configuration file reader did not handle HERE-documentation with non-used 
features correctly. [19075]  

Configuration options/system management tools 

• The configuration of both application and customer specific line styles has been 
improved. [17467]  

• It is now possible to generate DXF mapping files from inside of the application (File 
> Import > DXF > Generate DXF map file). [17512]  

• It is now possible to specify what application the DGN, DXF and SHAPE command 
line importers will use, so that coordinate transformations and hooks will use the 
correct configurations. [18438]  

• Debug tooltip texts are now shown in all views (previously only in the view which 
was active when entering debug mode). [18445]  

• It is now possible to specify default values also for geometry components (this was 
previously only possible for data components). [18480]  

• It is now possible to specify fill styles in a configuration file, similar to line strokes. 
[18789]  

• Scrolling using the mouse wheel is now significantly faster in the Metadata Manual 
(Administration menu). [18871]  

• The configuration options for attribute forms have been expanded with the 
introduction of support for static descriptive texts in html format. [18906]  

• The character encoding used in mapping files may now be specified when running the 
mapping script. [19033]  

Other 

• Geotools has been updated to version 2.5 and now handles some extra coordinate 
systems. [17895]  

• fop has been updated to version 0.95 [18323]  
• Jasperreports has been updated to version 3.5.2. [18438]  
• Swingx has been updated to version 1.0. [18470]  
• Jung has been updated to version 1.7.6 [18502]  
• PRTree has been updated to version 1.3. [18589, 19056]  


